Page 1 of 1

subject error book manager

PostPosted: Mon Aug 22, 2011 2:18 pm
by Anderson.susan
In the book records in book manager, I have entered subjects. These subject show up in the public view under "subjects", however when I click on the record I get the message (in a box) Could not load book ID 637 (each one seems to have a different random number assigned) Not found in database.
What does this mean??? How do I fix it? Thanks. Susan

Re: subject error book manager

PostPosted: Mon Aug 27, 2012 12:30 am
by Sagi
Are you still having this problem? I am using the latest 3.21 rev 1 version and am getting this error still. I posted a topic on it, but have not received any replies.

Here is a link describing my situation, which appears to be similar to what you experienced:


Re: subject error book manager

PostPosted: Mon Feb 18, 2013 2:15 am
by bmarcus
Hi guys, this is my first visit to the forum. Hopefully this is the correct place and procedure I follow,
otherwise correct me.

I'm having the same problem with the subject-book relation.
Also using version 3.21 rev 1. Is it still not solved?

This is what happens: I choose a subject, then from the list of books I choose a book.
Next the box "Could not load Book: Book ID 3 not found in database" appears.

I checked the table in phpMyAdmin "tblcollections_booksubjectindex" and found that this
is the ID and not the BookID for the subject. To solve this I have to dive in Archon, but
maybe someone solved it in the meantime?

Anyway I like Archon and it looks otherwise beautiful to me.

Greeting to everybody!

Re: subject error book manager

PostPosted: Fri Feb 22, 2013 11:10 am
by prom
This appears to be a bug in archon, I will look into this and get back to you.

Just FYI, the books manager will not be migrated to ArchivesSpace, so any use of it should be for experimental purposes only.