edits done in succession dont get saved

General bug reports for the Archon software.

Moderators: paulnsorensen, kylefox2, prom, rishel

edits done in succession dont get saved

Postby beltramie » Mon Oct 10, 2011 9:50 am

Hi, when we edit a record once, save, then try to make additional edits, the second edits are not getting saved. We can only make additional edits when we refresh the page displaying the record.

I dont see any CSS or javascript errors on my browsers warnings. Any idea what could be causing this?

Nat Wilson
https://archivedb.carleton.edu/
Environment:
Archon v 3.21
Linux
MySQL client version: 5.0.51a
PHP version 5.2.x
1 GB Storage,
20 GB Bandwidth
beltramie
 
Posts: 157
Joined: Mon Feb 16, 2009 3:58 pm
Location: Carleton College, Northfield MN

Re: edits done in succession dont get saved

Postby paulnsorensen » Wed Oct 19, 2011 12:06 am

Have you noticed this only occurring in certain types of fields? I'm presuming it's happening in the fields with the wysiwyg editor?

Also, in which browser is this behavior occurring?
paulnsorensen
Site Admin
 
Posts: 631
Joined: Mon Mar 31, 2008 8:55 am

Re: edits done in succession dont get saved

Postby beltramie » Thu Oct 20, 2011 10:04 am

Hmm,

Now I can only recreate the problem intermittently. But I am on Firefox 6 for Mac, and have experienced the problem on a couple different machines.

Often its only in the User Defined fields, I add a value, hit either done or save and the change is not preserved.

If I can get the error to start happening, and try to add a new User Defined Field, the Value is not being preserved, and I get this error message.

"Could not store User Field: Value not defined."

So it seems to be something with the Done button not actually keeping when I have typed in the Value field.

Nat
beltramie
 
Posts: 157
Joined: Mon Feb 16, 2009 3:58 pm
Location: Carleton College, Northfield MN

Re: edits done in succession dont get saved

Postby paulnsorensen » Sat Oct 22, 2011 7:16 pm

Ok I'll look into this...
paulnsorensen
Site Admin
 
Posts: 631
Joined: Mon Mar 31, 2008 8:55 am

Re: edits done in succession dont get saved

Postby paulnsorensen » Wed Mar 14, 2012 3:34 am

Is this still a problem? I can't seem to reproduce it.
paulnsorensen
Site Admin
 
Posts: 631
Joined: Mon Mar 31, 2008 8:55 am

Re: edits done in succession dont get saved

Postby beltramie » Fri Mar 16, 2012 11:53 am

K, yes. It happens a newly installed firefox 10.0.2, but not on Chrome.

I am using Mac 10.5.8 too.

So it looks like a browser issue. Dr. Harris, do you concur?
beltramie
 
Posts: 157
Joined: Mon Feb 16, 2009 3:58 pm
Location: Carleton College, Northfield MN

Re: edits done in succession dont get saved

Postby aschein » Wed Aug 29, 2012 10:11 am

I am sort of having the same issue. 95% of the time when I enter Subject Headings (SH) and hit save, it stays grayed out and spins until I have to hit control r and leave the page. The error code I get is:

Error: i.contentWindow is null
Source File: https://rosebud.library.northwestern.ed ... keditor.js
Line: 19

I am able to enter in SH the second time around. My question is, who corrects that, IT on our end or is this a bug in Archon. I am using a PC machine and Firefox 13.0.1, I have tried on a Mac and various browsers and still have had this problem.

Any help would be appreciated!!

Allison
aschein
 
Posts: 1
Joined: Wed Aug 29, 2012 10:06 am


Return to Archon Bugs

Who is online

Users browsing this forum: No registered users and 1 guest

cron