Error when using "Request hi-res copy" form

General bug reports for the Archon software.

Moderators: paulnsorensen, kylefox2, prom, rishel

Error when using "Request hi-res copy" form

Postby gjerdery » Fri Jul 06, 2012 11:15 am

We are currently running 3.21-rev1, and have found that the public user process for requesting hi-res copies of digital images ends with a confusing error message when the digital file has been granted "Preview Only" permissions. (an example: https://nordic.luther.edu/index.php?p=d ... ntent&id=2)

After the user fills out the request form and hits "Submit," a blank page with an error pop-up "Could not load File: Permission denied." appears. The user returns to the request form for the object. If one checks their email, an email has indeed been sent but it is missing the file title and name fields, but there is no notice of that on the subsequent screen in Archon. If we change the access privileges to "Full" for the image, the submission process correctly returns a pop that says something like "Thank you, your email has been sent."

I've tried to do a little digging into what is triggering this message.

The error message itself comes from the dbload function in digitallibrary/lib/file.inc.php (line 76). I think this is being called by createEmailDetailsForHighResolutionRequest in digitallibrary/lib/core/archon.inc.php (line 191).

Other than commenting out the permission check in ln 76 of file.inc.php, I'm not sure how to fix it. And I'm worried that getting rid of the permission check might break something more important. Any other ideas?
gjerdery
 
Posts: 20
Joined: Tue Apr 05, 2011 7:24 pm

Return to Archon Bugs

Who is online

Users browsing this forum: No registered users and 2 guests

cron