Total abject failure upgrading from 3.13r1 to 3.21

For issues with installing and configuring the Archon software to begin running on your webserver.

Moderators: paulnsorensen, kylefox2, prom, rishel

Total abject failure upgrading from 3.13r1 to 3.21

Postby jthiesen » Mon Nov 21, 2011 9:37 am

For the SECOND time, upgrading from 3.13r1 to 3.21 has failed. After I logged in, it went to step 2 of 5 and almost immediately displayed this long error message: An error occurred. Rolling back transaction --- CREATE TABLE tblCore_VersionCache ( VersionName varchar(50) NOT NULL DEFAULT" , VersionNumber varchar(10) NULL DEFAULT NULL, LastUpdated DATE NOT NULL ) DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci; ---MDB2 Error: already exists


At that point it hung up completely, no further progress, no response to the Next or Previous buttons.

Can anybody explain what's wrong here? We're running a plain vanilla LAMP system, no special features or split servers or anything. If the upgrade works at all, I can't see any reason why it wouldn't work on this system.

Is it even possible to do this upgrade? Has ANYONE been able to do it successfully?
jthiesen
 
Posts: 21
Joined: Tue Dec 14, 2010 2:07 pm

Re: Total abject failure upgrading from 3.13r1 to 3.21

Postby paulnsorensen » Wed Nov 30, 2011 4:22 am

Try dropping the tblCore_VersionCache table and rerunning the install.
paulnsorensen
Site Admin
 
Posts: 631
Joined: Mon Mar 31, 2008 8:55 am

Re: Total abject failure upgrading from 3.13r1 to 3.21

Postby jthiesen » Wed Nov 30, 2011 5:10 pm

I did try deleting the VersionCache table, via phpmyadmin.

When I re-ran the install after that, all I got was the screen showing the "Initializing..." message. It stayed up for ca. 20 hours before I closed the browser.

I also tried going from 3.13r1 to 3.14 instead of 3.21. I got exactly the same result, endless Initializing.
jthiesen
 
Posts: 21
Joined: Tue Dec 14, 2010 2:07 pm

Re: Total abject failure upgrading from 3.13r1 to 3.21

Postby paulnsorensen » Wed Nov 30, 2011 8:00 pm

It will never take 20 hours... if its like that for more than 20 minutes, it likely got killed on the backend. Can you see anything in the error logs (PHP and MySQL) to see what might be causing it? This has the behavior of an initial botched install that has left residual database changes -- that is unless you've customized your database schema.
paulnsorensen
Site Admin
 
Posts: 631
Joined: Mon Mar 31, 2008 8:55 am

Re: Total abject failure upgrading from 3.13r1 to 3.21

Postby jthiesen » Thu Dec 01, 2011 11:30 am

All the upgrades in the past up thru 3.13r1 went fine without any problems. Since then, every upgrade attempt has failed and we've restored from backups every time.

Unfortunately, I don't have the right permissions to get to the error logs, so I'm sort of stuck at this point. Don't really know what to do next.
jthiesen
 
Posts: 21
Joined: Tue Dec 14, 2010 2:07 pm

Re: Total abject failure upgrading from 3.13r1 to 3.21

Postby jthiesen » Fri Dec 02, 2011 10:27 am

A couple more questions:

Does it make a difference to the installation procedure if the server is using https vs. regular http?

Is there a change to the database structure going from 3.13r1 to later versions? If not, wouldn't it work just to replace the software and leave the database alone?
jthiesen
 
Posts: 21
Joined: Tue Dec 14, 2010 2:07 pm

Re: Total abject failure upgrading from 3.13r1 to 3.21

Postby beltramie » Fri Dec 02, 2011 11:05 am

I remember that there were some changes to table and field names from 3.13r1 to 3.20. Some extra tools I added stopped working after that upgrade and I had to update those names to get them working again.
beltramie
 
Posts: 157
Joined: Mon Feb 16, 2009 3:58 pm
Location: Carleton College, Northfield MN

Re: Total abject failure upgrading from 3.13r1 to 3.21

Postby paulnsorensen » Wed Dec 07, 2011 3:45 am

jthiesen wrote:Unfortunately, I don't have the right permissions to get to the error logs, so I'm sort of stuck at this point. Don't really know what to do next.


Is there anyway you can obtain them? There's not much I can think of that could be causing this without some further help. What browser version are you using to run the upgrade?
paulnsorensen
Site Admin
 
Posts: 631
Joined: Mon Mar 31, 2008 8:55 am

Re: Total abject failure upgrading from 3.13r1 to 3.21

Postby jthiesen » Wed Dec 21, 2011 12:26 pm

I've used both Firefox and Chrome in trying to upgrade. Both are at the most recent version.
jthiesen
 
Posts: 21
Joined: Tue Dec 14, 2010 2:07 pm


Return to Installation/Configuration Issues

Who is online

Users browsing this forum: No registered users and 2 guests

cron