3.21 usergroup permissions

For issues with installing and configuring the Archon software to begin running on your webserver.

Moderators: paulnsorensen, kylefox2, prom, rishel

3.21 usergroup permissions

Postby cnelson » Wed Mar 14, 2012 10:25 am

Hi there, I am trying to create a new usergroup called "Repository Admin". We are using an Archon instance with multiple repositories in it, for each one I'd like to have a "Repository Admin" - someone who has as full control over that repository as possible, without having full control over the instance itself.

I gave this user Read, Add, Update and Delete permissions for the Database Management module. NOT "Full Control" at first. My user reported that they were getting a "permission denied" error when they tried to import an EAD file. I went back in and added "Full Control" permissions to the user, and it seemed to work.

My question is: given that I had already given then Read, Add, Update and Delete permissions, what more did checking "Full Control" do? Are there some other hidden permissions in the system? It seems like checking the other 4 should have worked to begin with, and I'm a little confused. If you could clarify, that would be great! Thanks!

Posts: 66
Joined: Tue Jan 05, 2010 11:23 am

Return to Installation/Configuration Issues

Who is online

Users browsing this forum: No registered users and 1 guest