installing on wamp

For issues with installing and configuring the Archon software to begin running on your webserver.

Moderators: paulnsorensen, kylefox2, prom, rishel

installing on wamp

Postby eddywebs » Thu Mar 11, 2010 4:18 am

Hi , I had been trying to install archon 3.00 on my localhost wampserver lately.
It asked for pear with MDB2 package installed , which I gladly did on php 5.2.9

even after installing the pear package with MDB2 the install page showed
"MDB2 is either not correctly installed or not in your include paths. "

I really have no idea how go ahead with this , I tried messing with the includes path , it seems like I am doing something wrong
Any suggestions what seems to be the problem ?
eddywebs
 
Posts: 11
Joined: Thu Mar 11, 2010 4:13 am

Re: installing on wamp

Postby paulnsorensen » Thu Mar 11, 2010 2:03 pm

Did you also install the MDB2-mysql driver?
paulnsorensen
Site Admin
 
Posts: 631
Joined: Mon Mar 31, 2008 8:55 am

Re: installing on wamp

Postby eddywebs » Thu Mar 11, 2010 9:58 pm

[quote="paulnsorensen"]Did you also install the MDB2-mysql driver?[/quote]

Yeah Ive installed the MDB2 and the PEAR libraries and using the tutorial found at http://www.firehost.com.au/blog/mdb2/in ... -32-64-bit

and went successfully .

Still get the MDB2 missing or invalid path error , I know that the MDB2 is installed now but have no idea if its finding the right path or not :?
eddywebs
 
Posts: 11
Joined: Thu Mar 11, 2010 4:13 am

Re: installing on wamp

Postby paulnsorensen » Thu Mar 11, 2010 10:20 pm

Can you use phpinfo to see what your include_path is? The PEAR modules should be installed to your php/pear directory, I believe.
paulnsorensen
Site Admin
 
Posts: 631
Joined: Mon Mar 31, 2008 8:55 am

Re: installing on wamp

Postby beltramie » Thu Jan 27, 2011 4:04 pm

I was talking with a colleague that is having this same problem. Looks like the address for the link above has changed. Here is an updated link.

http://www.firehost.com.au/blog/mdb2/in ... -32-64-bit
beltramie
 
Posts: 157
Joined: Mon Feb 16, 2009 3:58 pm
Location: Carleton College, Northfield MN

Re: installing on wamp

Postby arobers1 » Tue Feb 08, 2011 11:20 am

My colleague created these steps for installing on WAMP. He links to a couple of tutorials on installing PEAR. Hope this helps!

Steps for installing Archon locally on WAMP

Make sure PHP 5.2.9-2 is installed on WAMP (if not, install through the WAMP PHP interface -->PHP-->Versions-->'Get More') Once installed, make sure 5.2.9-2 is selected for use in WAMP.

Download Archon and put the Archon folder and the install.php file into c:\wamp\www\

Follow the steps here:http://www.truecms.net.au/blog/mdb2/installing-pear-mdb2-wamp-server-windows-7-vista-xp-32-64-bit

Still in command line, follow the steps on this page: http://www.archon.org/mdb2.html (step one will prompt cmd to tell you that pear MDB2 is already installed--for step 2, use the mysql version.

Check the phpinfo() page and under the "Configuration: PHP Core" table, make sure the following is listed as an include_path: ".;c:\wamp\bin\php\php5.2.9-2\pear." If not, use the WAMP php.ini interface to add the line
include_path=".;c:\wamp\bin\php\php5.2.9-2\pear" under the "Paths and Directories" heading.

Open c:\wamp\www\Archon\config.inc.php and set the following variables:

$_ARCHON->db->ServerType = 'MySQL';

$_ARCHON->db->ServerAddress = 'localhost';

$_ARCHON->db->Login = 'root'; (Unless you chose a different mysql login)

$_ARCHON->db->Password = '' (empty single quotes);

$_ARCHON->db->DatabaseName = 'archon'; (No caps in mysql database names is preferable)

In WAMP, launch phpMyAdmin and on the homepage look for 'Create a new database' and type in 'archon' (no quotes) and click 'Create.'

In a web browser, go to http://localhost/archon and check for any errors. Then follow the 12-step Archon set-up process.
arobers1
 
Posts: 3
Joined: Tue Feb 08, 2011 11:16 am

Re: installing on wamp

Postby nwc_librarian » Wed Dec 21, 2011 3:48 pm

I found the summary provided by arobers1 to be very helpful. As I was new to server environments, databases, etc., I thought I would post my experiences in hopes that they will prove helpful to others.
My first mistake was attempting to load Archon 3.20 and Archon 3.21. For the life of me, I couldn't get it to work. Then I realized that I should follow instructions elsewhere on the forum. These indicate that you first must have Archon 2.22 running. Once I made this change, it installed with zero problems.
My second mistake was not turning WAMP online (DOH!!!) and making sure all services were started.
My third mistake wasn't really a mistake but rather a challenge I had difficulty overcoming. Initially, I could not install the MDB2 portion as below via command line because CMD told me it could not open the input file. ARGHHH!!! I had to download the go-pear.bat file into the PEAR directory at wamp > bin > php > php5.2.9-2 (not into the second, deeper PEAR directory) and double click it and walk through it accepting its recommendations (followed by double clicking the PEAR.env file to make the directory changes in Windows 7; may not be necessary).
Other things that tripped me up. I spent a lot of time playing with the location of the include_path in the php.ini file right. This was wasted time, apparently. Here is how it looks on the working version:

;include_path=".;c:\wamp\bin\php\php5.2.9-2\pear"

; UNIX: "/path1:/path2"
;include_path = ".:/php/includes"
;
; Windows: "\path1;\path2"
;include_path = ".;c:\php\includes"

I realize that this might seem basic or rudimentary even to many of you, but this was hard-won knowledge for me.
nwc_librarian
 
Posts: 4
Joined: Wed Dec 21, 2011 3:29 pm


Return to Installation/Configuration Issues

Who is online

Users browsing this forum: No registered users and 1 guest

cron